Mousepad Master Help

Jannis Pohlmann jannis at
Sat May 5 11:14:46 CEST 2012

On Fri, 04 May 2012 21:38:14 -0700
Matthew Brush <mbrush at> wrote:

> Hi,
> I have Nick's new Mousepad re-write all ready to go into master. I
> have tagged the old master branch as `legacy` and made a copy of it
> in the `legacy-master` branch. Now I need to push "my" master, which
> is causing a reject. I tried to push with `--force` and `:master` and
> also to delete the old master branch and push mine but it won't let
> me delete master with same error as last. I checked the history in
> `gitk` and it looks OK, so I think maybe some translations are
> messing with merging somehow?. I tried to `git pull --rebase` from
> remote but it wouldn't succeed.
> Can someone "force" push the new master branch[0] to or 
> tell me what I can do to put my "local master" into the one stored on 
> myself?

Force-pushing and rewriting the history of a non-personal branch are
considered really, really bad practice. You don't want to do that. You
have two choices for getting your changes into master: merge or rebase. 

What exactly is wrong with checkout out the current master branch and
running "git merge <your branch>" and then resolving whatever conflicts
you end up having?

  - Jannis

More information about the Xfce4-dev mailing list