xffm compile fails

Edscott Wilson Garcia edscott at xfce.org
Fri Feb 3 03:48:13 CET 2006

On Thu, 2 Feb 2006, Tuukka Mäkinen wrote:

> Edscott Wilson Garcia wrote:
>> On Thu, 2 Feb 2006, Tuukka Mäkinen wrote:
>>> Hi
>>> I checked out xffm a moment ago (rev 18876) and my compile fails. This
>>> is with
>>> using installer.sh and not passing any parameters.
>> Something must be wrong with your checkout, this is what I get for
>> revision:
>> trunk $ svn update
>> En la revisin 19715.
> Hmm wonder what happened with. I use Gentoo and the installation script I have
> (little stupidly) always updates the files first so I *did* run update. Now I
> made a manual update to make sure and got revision 19716. Running the script
> correctly tries to update too but can't of course find anything since the tree
> was just manually updated. Oh well it's compiling now.
> Still no go. Just updating didn't help, I got the same error message, so I tried
> setting PKG_CONFIG_PATH to different values but that didn't help either. Then
> finally it dawned on me that Gentoo installs other modules with prefix=/usr but
> since the Gentoo way fails on xffm I run installer manually forgetting the
> default prefix is /usr/local. Correct prefix and it compiles nicely.

I see. I will try to make the installer.sh script a bit more robust to try 
and detect this kind of situation.



More information about the Xfce4-dev mailing list