4.4beta2 logout window not working

James Turner jturner at gemini.edu
Sat Aug 12 21:43:37 CEST 2006

> Is xfce4-session running? I've had the same problem in
> (brazillian portuguese translation), I've solved the SUDO problem
> adding these to the /etc/sudoers :
> /sbin/shutdown,/sbin/reboot,/sbin/halt,/usr/sbin/xfsm-shutdown-helper
> Where "user" is your user name.
> Also, change the location of the xfsm-shutdown-helper.

Yes, xfce4-session is running. Also, to answer Brian Tarricone's question
from earlier (sorry I didn't reply sooner), xfce4-session-logout produces
no output on the terminal.

I did add xfsm-shutdown-helper to sudoers, apparently successfully. I also
added halt at some stage, but not shutdown etc. My attempt to quit doesn't
get that far though -- I don't even get a logout window. Neither
xfsm-shutdown-helper nor xfce4-session-logout do anything when run
explicitly from a terminal, so the problem doesn't seem to be finding the
command. It's therefore hard to imagine that moving xfsm-shutdown-helper
will help, but I could try it.

> restart xfce and try adding a Quit Action Button on the panel (not the
> menu!) and click it. My problem was solved like that, unfortunately i
> did not solve the menu's problem.

I do have a quit button on the panel, but it doesn't work either,

I have come up with a tolerable workaround, however, which is just to
replace the "Quit" menu option with an item called "Quit" that launches
"sudo /sbin/halt"!!

Thanks for the suggestions,


More information about the Xfce mailing list