4.4beta2 logout window not working

LaPeq FCI lapeqmack at gmail.com
Sat Aug 12 00:00:29 CEST 2006

> I have compiled Xfce 4.4 beta 2 from source on Debian Sarge (Linux 2.4)
> and installed it in /usr/local. In general it is working well, but when
> I select "Quit" from the menu or press the logout icon on the panel,
> nothing at all happens. The logout dialogue does not appear. Running
> xfce4-session-logout or /usr/local/libexec/xfsm-shutdown-helper also
> produces no result. The latter says "XFSM_SUDO_DONE" and then "FAILED"
> on the terminal. I don't see anything special in .xsession-errors, except
> a message from startxfce4 at the top, saying that an X server is already
> running (I am starting Xfce via gdm).
> Searching on the Web, I found a similar Debian-related problem, which
> the user had solved by linking /usr/X11R6/bin/iceauth to a symbolic link
> in /usr/bin. That doesn't make any difference for me, however.
> Any suggestions would be much appreciated. I nearly have my old computer
> ready to hand over to an orphans' centre here in Chile :-).

Is xfce4-session running? I've had the same problem in
(brazillian portuguese translation), I've solved the SUDO problem
adding these to the /etc/sudoers :


Where "user" is your user name.
Also, change the location of the xfsm-shutdown-helper.

restart xfce and try adding a Quit Action Button on the panel (not the
menu!) and click it. My problem was solved like that, unfortunately i
did not solve the menu's problem.

> _______________________________________________
> Xfce mailing list
> Xfce at xfce.org
> http://foo-projects.org/mailman/listinfo/xfce
> http://www.xfce.org

LaPeq - Laboratório de Pesquisa Científica da FCI

More information about the Xfce mailing list