Xfce Menu broken

Bob Plantz plantz at cds1.net
Mon Nov 7 00:16:34 CET 2005

>> My Xfce Menu no longer works.
>> Ubuntu distro (5.10 - breezy badger) on amd64.
>> First time I installed, it worked fine. I went back to gnome for a
>> couple of weeks and xfce no longer worked. I reinstalled everything
>> using synaptic. It took several tries to even get xfce working again. I
>> had to mark everything that had "xfce" in its name or description for
>> reinstallation.
>> The Xfce Menu icon shows in the panel, and its Item propeties show the
>> Menu file to be /etc/xdg/xfce4/desktop/menu.xml.
>> I have a copy of menu.xml in ~/.config/xfce4/desktop/ and in
>> /etc/xdg/xfce4/desktop/.
>> I can go to Xfce Settings Manager -> Desktop Settings and click on the
>> Menu tab, then click on Edit desktop menu. I see reasonable things. For
>> example, there's "Run Program..." after the first separator, another
>> separator, then "Terminal", etc.
>> Using ps -A, I see that xfce4-session, xfce-mcs-manage, xfwm4,
>> xftaskbar4, xfdesktop, and xfce4-panel are all running.
>> I'm puzzled.

> Sorry, but you haven't actually said what's wrong.  "Doesn't work"
> doesn't give me much to go on.

Sorry about that.

When I mouse over the icon in the panel, I get "Xfce Menu" as expected.

I click on it and nothing happens.

Right-mouse click on the desktop or xfdesktop -menu in a terminal do nothing.

Center-mouse click on the desktop or xfdesktop -windowlist in a terminal give me a window list, as adverised.

My take is that I'm close, but it's some little thing.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.xfce.org/pipermail/xfce/attachments/20051106/f681b8bd/attachment.html>

More information about the Xfce mailing list