Cannot run mozilla-1.3.1 from panel icon

Rich Shepard rshepard at
Thu Jun 12 15:54:22 CEST 2003

On 12 Jun 2003, Stephen Kuhn wrote:

> It would appear as though there is a problem with system paths - and
> possibly lib paths as well.


  Nope, that's not it.
> Else, a trick would be to create a script in your ~/home/yournamehere/
> directory calling the program and then change the link in the panel to
> suit the new script (make sure you chmod +x scriptname prior to
> attempting to run it).

  That's exactly what I did and was stumped when it didn't work.

  However, I just found the problem and fixed it. For the benefit of future
generations I'll pass on what I've learned.

  When I upgraded mozilla from 1.2.1 to 1.3.1 the default installation
directory changed from /usr/lib/mozilla-<version> with a startup script as
/usr/bin/mozilla to /usr/local/mozilla with a start up script of

  On the panel's icon, I changed the command line from /usr/bin/mozilla to
/usr/local/mozilla/, but that didn't work. Eventually I wrote
a three-line shell script and this worked from the command line but not from
the panel icon.

  This time, rather than retyping the comand line on the icon's dialog box,
I used the "browse" button and discovered that the path was set to
/usr/local/mozilla although the command line read, "/home/rshepard/mozilla".
I clicked my way up and down the filesystem tree and let the dialog box put
the string in the command line of the icon.

  This fixed the problem. Shrug. I've not had to do this before, but what
the heck: as long as it works I can go back to my real life now.

Thanks to everyone who offered suggestions,


Dr. Richard B. Shepard, President

                       Applied Ecosystem Services, Inc. (TM)
            2404 SW 22nd Street | Troutdale, OR 97060-1247 | U.S.A.
 + 1 503-667-4517 (voice) | + 1 503-667-8863 (fax) |

More information about the Xfce mailing list