[Thunar-dev] eject usb-harddrive

Simon Steinbeiß simon.steinbeiss at elfenbeinturm.at
Tue Apr 29 16:30:10 CEST 2008


> Using 'eject' doesnt work either?
Well, actually using "eject" in thunar gives me a very generic error:
Failed to eject "WD Passport". An unknown error occured.

> Maybe a more general solution (using hal or udev rules, or something like
> that) would be better, and cross-desktop?
Well, I tried my best at writing a script (sorry, my skills are really quite low) that
would be executed whenever I plugin the hdd (via a udev-rule) and give me a notification
icon (with zenity) with which I could eject it. The script seemed to work fine with
xubuntu 7.10 but since I switched to 8.04 it's stuck again in a loop... you can inspect
the great failure here (if you really like): http://pastebin.org/32753
(However if you simply execute this script in a shell it does exactly what I ask for.
The problem seems to be that udev doesn't really execute the RUN-command in a shell.)

> What an ugly workaround (my impression is that the Ubuntu folks are
> great at implementing ugly workarounds instead of fixing the real
> issue).
hmmm, yeah, well I guess you're right. As I said, I'm really not good at this.

> Forgot to ask one thing: do you have an "eject" button for your drive,
> or only "unmount"? The Xfce 4.4.2 release was somewhat buggy regarding
> the detection of removable media and providing the eject funktion in
> the GUI. If you only see "unmount" in the context menu of the drive,
> you could try exo-eject in the command line to see if that works for
> you.

As mentioned above, I do see the "eject" button. Anyways, I tried "exo-eject" to see
whether this would give me a more comprehensive error message, well here it is (the
command I ran was "exo-eject
-h SAME_AS_BELOW -e"):
Failed to eject
No property info.interfaces on device with
id /org/freedesktop/Hal/devices/storage_serial_WD_1200BEVExternal_575845333037343330353232_0_0.

> My girlfried owns a WD Passort drive (2,5" external 160 GB hard disk),
> so I'll try to reproduce the issue.

thanks, sounds great!


More information about the Thunar-dev mailing list