Xfce 4.18 dependencies versions

Romain Bouvier skunnyk at alteroot.org
Sun Jul 25 19:28:19 CEST 2021

Hi :)

4.18 development cycle is already started (https://wiki.xfce.org/releng/4.18/roadmap), we've seen tons of commits in thunar and some core components (GSoC 2021 effect), but we haven't discussed yet the lib/dependencies requirements. 

One question is : do we want to be able to compile Xfce 4.18 (which is far from being released) on Ubuntu 20.04 (LTS) and CentOS/RockyLinux 8 (this one might be problematic because it only have gtk 3.22 and glib2 2.56). My opinion is : we can ignore them.

What I propose, if we are ok to not "support" Ubuntu 20.04 / CentoS 8 (by the time we release 4.18, maybe Ubuntu 22.04 (next lts) will be already released btw). 

- gtk >= 3.24, so we can ditch tons of "#if GTK_CHECK_VERSION" macros in core
- glib-2.0 >= 2.66 (note: ubuntu 20.04 (lts) only have 2.64)
Same version for gmodule-2.0, gobject-2.0, gthread-2.0, gio-2.0 and gdbus
- libcairo >= 1.16
- gdk-pixbuf-2.0 >= 2.40


More information about the Xfce4-dev mailing list