[xfce4-terminal] Large delay in prompt echoing after completion of a command which runs inside a tmux session

Igor Zakharov f2404 at yandex.ru
Tue Sep 26 14:36:55 CEST 2017

26.09.2017, 06:05, "Daniel Fishman" <quantera at gmail.com>:
> I encountered an issue which occurs when tmux is used on xfce4-terminal
> but doesn't occur on xfce4-terminal alone or when tmux is used on other
> terminals (like konsole, xterm or gnome-terminal). Since the problem
> occurs only in a combination with tmux, I reported it to tmux's developer
> (see https://github.com/tmux/tmux/issues/1089), but according to the results
> of his investigation it seems that tmux behaves as expected, and there
> is no indication that the problem is in the tmux.
> In addition, the problem is hard to reproduce since it occurs only on
> a 32-bit machine, and most people don't have such machines any more.
> Therefore, I cannot really report the problem as xfce4-terminal's bug,
> but maybe somebody on the list may have an idea what is the reason for
> the problem or what can I do to investigate it enough for a bug report
> (if indeed the problem is related to xfce4-terminal).
> Basically, all the fine details of a problem (including the relevant logs)
> are available in github's issue report (see the link above), but the
> gist of the issue is as follows:
> When some short cli command is ran in tmux session on xfce4-terminal,
> then after a command completes the prompt is not echoed back immediately,
> but there is a delay of 30-60 seconds between command's completion and
> prompt's echoing, making it seem as though the command is still running.
> If during this interval (after the command really completes but before the
> prompt is echoed) you press any key, then the prompt is immediately
> printed.
>  From Nicholas' (who is the tmux developer) investigation it seems as though
> the tmux itself writes the prompt as soon as the command completes, but the
> terminal still doesn't show it.
> Does this problem rings any bells?

Hi Daniel,

Thanks for reporting this!

The problem is looking really weird, however, especially given with the fact that you can only reproduce it on a 32-bit machine. Have you tried only one 32-bit machine? Do you have another 32-bit one for a test?
Another strange thing is that gnome-terminal does not seem to have the problem, though it's also based on the vte widget. What gnome-terminal version have you tried?


More information about the Xfce4-dev mailing list