Building XFCE 4.8 on Centos 5.7

Olivier Fourdan fourdan at
Tue Oct 18 18:13:01 CEST 2011

On Tue, Oct 18, 2011 at 5:54 PM, Alasdair Thomson
<gzunkal at> wrote:
> I’m trying to build 4.8 on Centos 5.7, but it’s complaining about:
> checking for gobject-2.0 >= 2.18.0... found, but 2.12.3
> *** The required package gobject-2.0 was found on your system,
> *** but the installed version (2.12.3) is too old.
> *** Please upgrade gobject-2.0 to atleast version 2.18.0, or adjust
> What I’d like to ask is how difficult would it be for me to build
> gobject-2.0? Considering I found gobject-2.0 in the glib2-devel package it
> suggest that if I want to update it I’m going to be basically building gnome
> and that’s probably quite a bit of effort.
> The version of XFCE that’s included in the repository is 4.4, but I just
> wanted something a bit more recent.

Yes, el5 is a bit old wrt the requirements of xfce 4.8

What you can do, if you are brave enough and ready to build quite a
few dependencies manually, is to build and install all the
requirements in a separate tree, in /opt for example, and use that to
build and install xfce 4.8 there as well.

Basically, you'll end up with a separate, independent tree with all
the required packages in the expected version.

But that's a bit of a daunting task to be honest... considering that
xfce 4.8 is in epel for el6 :)


More information about the Xfce4-dev mailing list