[Xfce4-commits] <xfce4-session:master> Reuse existing ConsoleKit sessions (bug #6685).

Mike Massonnet mmassonnet at gmail.com
Wed Sep 8 22:06:40 CEST 2010

2010/9/8 Enrico Tröger <enrico at xfce.org>:
> On Wed,  8 Sep 2010 10:08:01 +0000 (UTC), Jannis wrote:
>>Updating branch refs/heads/master
>>         to 35c620aa3749581580e0917ff7c2db1c223564a8 (commit)
>>       from 2e4be9da0575c4fd76e6b50c7e75f7eb7a56ef45 (commit)
>>commit 35c620aa3749581580e0917ff7c2db1c223564a8
>>Author: Jannis Pohlmann <jannis at xfce.org>
>>Date:   Wed Sep 8 12:02:46 2010 +0200
>>    Reuse existing ConsoleKit sessions (bug #6685).
> This and the related commit in xfce-utils broke it again for me.
> After I changed the ck-l-s command in $prefix/etc/xdg/xfce4/xinitrc as
> Mike suggested yesterday on the Xfce users list, it worked fine. I
> could reboot/halt my system and also mount devices (USB stick) in my
> case.
> Now, with the change above, I can't do any of these things.
> xfce4-session-logout only offers Logout, reboot and halt are disabled.
> Also mounting my USB stick doesn't work with this change.
> I don't use any display manager, just plain console login as in good
> old days.

I can second that. Now i can see only one CK session, so the patch
works as intended. But I'm not able to shutdown/reboot or mount with
gvfs-mount and this if I log in through a tty using startxfce4.

I don't see why I have to use startx or add polkit configuration
files, really startxfce4 should just work<tm>! If I login through GDM
everything works fine (it already worked fine with it before, in my

> Has anyone else similar problems or is just me?
> Btw, all this happens on Debian Testing.

You are not alone, and this happens on ArchLinux.

I have restored "ck-l-s dbus-l" inside xinitrc and login through a tty
works fine as long as you don't use the pam_ck_connector plugin[1]
(make sure it is commented inside /etc/pam.d/login). Patch is updated
on bug 6690[2]. The "if" condition checks whether ck-l-s exists and
that a session isn't already launched, so running it through GDM is

I wonder what happens with Slim or XDM, but I'm not gonna test that,
this is just a random mess that Freedesktop has bring up :p

[1] NB: when using the pam_ck_connector plugin I have automatically an
XDG_SESSION_COOKIE variable set and a ck-session open (seen with
ck-list-sessions) but when reusing this session nothing was working
inside X, perhaps it has to do that the info for x11-display was empty
as displayed by ck-l-s...

[2] http://bugzilla.xfce.org/show_bug.cgi?id=6690#c6

> Regards,
> Enrico

PS: Glade to see this "bug" is getting pushed forward, but it ain't
perfect yet ;-)

More information about the Xfce4-dev mailing list