failing of object initializing

Kees Scherpenhuijzen noik00 at
Wed Oct 21 18:13:53 CEST 2009

2009/10/21 David Mohr <squisher at>:
> On Wed, Oct 21, 2009 at 9:40 AM, Kees Scherpenhuijzen <noik00 at> wrote:
>> Hey there,
>> Since the change from thunar-vfs to GIO i'm getting back in touch with
>> Thunar. I'm trying to create a plugin for thunar.
>> I've tried making a new object with a window in it but this seems to
>> be failing all the time.
> Hi,
> please be more specific. How does it fail? It does not compile? If it
> does, do you get runtime output on the console?
>> The creation of the object i tried as followed:
> It would be more useful if you would upload these files somewhere and
> include the URL, or possibly attach the files, instead of adding them
> to the email text.
> And just out of curiosity, what task is your plugin going to perform?
> ~David
> _______________________________________________
> Xfce4-dev mailing list
> Xfce4-dev at

I'm sorry for not including a link to the app. I'm waiting for mij SVN
update to get clearance on the GIT again. then i will upload it again.

But the app is compiling fully without any problems. On runtime when i
*click* on a button where this window is made, it gives this error:
(lt-Thunar:9832): GLib-GObject-CRITICAL **: g_object_new: assertion
`G_TYPE_IS_OBJECT (object_type)' failed


More information about the Xfce4-dev mailing list