4.6 installer: glade files installed to global prefix

Enrico Tröger enrico.troeger at uvena.de
Sun Jan 18 09:59:08 CET 2009

On Sun, 18 Jan 2009 04:35:49 +0100, Jannis Pohlmann <jannis at xfce.org>


>I just played with the installer a bit and created the necessary files
>to create an installer for 4.6. I did a test run, installing
>to /home/jannis/local as a normal user and I ran into a problem with
>the gladeui files. I don't have the log at hand right now, but I know
>that the build scripts tried to install stuff from libxfcegui4/glade/
>into the gladeui prefix (/usr/share/glade3 or something). 
>So, for the installer this is a bit problematic. A lot of people will
>try to run the installer as a normal user and if they happen to have
>libgladeui they will run into this problem. Any ideas how to fix that?

I use the following ./configure options to build my Xfce
in /home/enrico/apps/xfce-svn:

for libxfcegui4:

for xfce-utils:

$prefix is:

And to get the libxfce4gui stuff working when running, you need to make
the LIBGLADE_MODULE_PATH public, the following is a snippet from my

# for libxfcegui4
export LIBGLADE_MODULE_PATH=/home/enrico/apps/xfce-svn/libglade/2.0/:

Not really convenient but at least it works.


Get my GPG key from http://www.uvena.de/pub.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20090118/06241666/attachment.pgp>

More information about the Xfce4-dev mailing list