4.6 installer: glade files installed to global prefix

Jannis Pohlmann jannis at xfce.org
Sun Jan 18 04:35:49 CET 2009

Hey guys,

I just played with the installer a bit and created the necessary files
to create an installer for 4.6. I did a test run, installing
to /home/jannis/local as a normal user and I ran into a problem with
the gladeui files. I don't have the log at hand right now, but I know
that the build scripts tried to install stuff from libxfcegui4/glade/
into the gladeui prefix (/usr/share/glade3 or something). 

So, for the installer this is a bit problematic. A lot of people will
try to run the installer as a normal user and if they happen to have
libgladeui they will run into this problem. Any ideas how to fix that?

One idea of course would be to force the gladeui to be ignored when
building the sources shipped with the installer.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20090118/126c164b/attachment.pgp>

More information about the Xfce4-dev mailing list