libxfcegui4 install error without gladeui

Brian J. Tarricone bjt23 at
Sat Jun 28 00:16:46 CEST 2008

Enrico Tröger wrote:
> On Wed, 25 Jun 2008 10:21:54 -0700, "Brian J. Tarricone"
> <bjt23 at> wrote:
>> Enrico Tröger wrote:
>>> Hi,
>>> I just tried to install libxfcegui4 (make install) and got the
>>> following error:
>>> make[3]: Entering directory
>>> `/home/enrico/src/xfce/libxfcegui4/trunk/glade' make[3]: Nothing to
>>> be done for `install-exec-am'.
>>> test -z "" || /bin/mkdir -p ""
>>> test -z "" || /bin/mkdir -p ""
>>> test -z "/usr/lib/libglade/2.0" || /bin/mkdir -p
>>> "/usr/lib/libglade/2.0" /bin/mkdir: cannot create directory
>>> `/usr/lib/libglade': Permission denied make[3]: ***
>>> [install-libglademoduleLTLIBRARIES] Error 1
>>> There seems to be something wrong with the glade code. I have
>>> installed libglade but prefer to not install gladeui as this
>>> requires some Gnome dependencies (gnome-keyring, bonobo, gconf, all
>>> such stuff).
>> No, there's nothing wrong with it.  That has nothing to do with
>> gladeui. Read it again -- /usr/lib/libglade is failing to be
>> created.  It's required now, and this unfortunately breaks non-root
> I see, but I guess you agree this isn't a good situation.

Sure, but I don't have a better solution that won't make things 
difficult for the common case of a root/systemwide install.

>> installs.  If you know of a way to install libglade modules to a
>> non-root location without breaking the install for regular users
>> (missing widgets in the settings dialog would suck), please submit a
>> patch.
> First, the module path could be changed in when
> installing to a non-default prefix.

That breaks.  /usr is non-default.  /opt/xfce4-svn is non-default.  But 
they're both locations usually only writable by root, and if you install 
the libglade module there, things will break.

> Then we need to fix the path for the library.
> According to,
> GLADE_MODULE_PATH should work, on my system it doesn't or I didn't set
> it correctly (tried %prefix, %prefix/lib, %prefix/lib/libglade, %
> prefix/lib/libglade/2.0 and prefix/lib/libglade/2.0/

I think GLADE_MODULE_PATH is for the glade GUI editor, not libglade. 
But I might be mistaken.  Either way, there's probably an env var that 
works for libglade.  But: for a root install, we always want to install 
to a location that libglade will *automatically* pick up with no extra 
user configuration.

> Another possibility according to above mentioned documentation could be
> to set the library path in glade/ like
> <library>%prefix/lib/libglade/2.0/</library>
> But this file seems to be not (yet) be used at all? Maybe I'm missing
> something, I don't have any real clue about this libglade stuff at all.

The xml catalog is only installed for the glade GUI editor; has nothing 
to do with libglade (and indeed doesn't even get installed if you don't 
have the GUI editor installed).

I guess we could just have a --with-libglade-module-path option to 
configure so you could override it yourself.  Duh, that's simple enough. 
  Silly me.


More information about the Xfce4-dev mailing list