libxfcegui4 install error without gladeui

Enrico Tröger enrico.troeger at
Fri Jun 27 20:37:43 CEST 2008

On Wed, 25 Jun 2008 10:21:54 -0700, "Brian J. Tarricone"
<bjt23 at> wrote:

> Enrico Tröger wrote:
> > Hi,
> > 
> > I just tried to install libxfcegui4 (make install) and got the
> > following error:
> > 
> > make[3]: Entering directory
> > `/home/enrico/src/xfce/libxfcegui4/trunk/glade' make[3]: Nothing to
> > be done for `install-exec-am'.
> > test -z "" || /bin/mkdir -p ""
> > test -z "" || /bin/mkdir -p ""
> > test -z "/usr/lib/libglade/2.0" || /bin/mkdir -p
> > "/usr/lib/libglade/2.0" /bin/mkdir: cannot create directory
> > `/usr/lib/libglade': Permission denied make[3]: ***
> > [install-libglademoduleLTLIBRARIES] Error 1
> > 
> > There seems to be something wrong with the glade code. I have
> > installed libglade but prefer to not install gladeui as this
> > requires some Gnome dependencies (gnome-keyring, bonobo, gconf, all
> > such stuff).
> No, there's nothing wrong with it.  That has nothing to do with
> gladeui. Read it again -- /usr/lib/libglade is failing to be
> created.  It's required now, and this unfortunately breaks non-root

I see, but I guess you agree this isn't a good situation.

> installs.  If you know of a way to install libglade modules to a
> non-root location without breaking the install for regular users
> (missing widgets in the settings dialog would suck), please submit a
> patch.

First, the module path could be changed in when
installing to a non-default prefix.

Then we need to fix the path for the library.
According to,
GLADE_MODULE_PATH should work, on my system it doesn't or I didn't set
it correctly (tried %prefix, %prefix/lib, %prefix/lib/libglade, %
prefix/lib/libglade/2.0 and prefix/lib/libglade/2.0/

Another possibility according to above mentioned documentation could be
to set the library path in glade/ like


But this file seems to be not (yet) be used at all? Maybe I'm missing
something, I don't have any real clue about this libglade stuff at all.


Get my GPG key from
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <>

More information about the Xfce4-dev mailing list