Xfconf troubles

Jannis Pohlmann jannis at xfce.org
Thu Jul 10 14:10:57 CEST 2008

Am Thu, 10 Jul 2008 10:39:39 +0200
schrieb Enrico Tröger <enrico.troeger at uvena.de>:

> Hi,
> yesterday I compiled the latest SVN version of Xfce (include xfconf
> and xfce4-settings) but didn't restart Xfce.
> So, as I booted my system today, it made Boom and I got the changes.
> The changes mean that I lost most my settings for xfdesktop and the
> whole UI stuff.
> I had to reconfigure my GTK theme, icon theme, xfdesktop config and
> similar. Most of these weren't a problem except for two things:
> a) I ended up with scary fonts...I'm not able to make the fonts look
> like before. This is really, really annoying and hard to describe but
> my system looks ugly. I already tried all the fonts I've installed
> here (which didn't change lately, so I have the same installed as
> before). And I tried various hinting settings. All without any
> noticeable success.
> Then I tried to play with setting a custom DPI value, as default 96
> was displayed but it wasn't active. I activated the checkbox and
> decreased the value, this caused even more strange UI effects and
> finally killed all my terminals and didn't let me restart it until I
> restarted my whole X server.

Hm. And you did have xfsettingsd and xfce4-settings-helper running?

> The settings dialog for xfdesktop didn't allow me to add a custom
> wallpaper. It provided a list of installed wallpapers but the little
> "+" (plus) button for adding other files is insensitive. Furthermore,
> IMO this button should be a real GTK stock button including the text
> "Add" not only the icon.

AFAIK, the wallpaper settings are just not finished yet.

> Finally, I found this message in the logs which may be related to all
> my problems with the new xfconf stuff which was just disappointing and
> frustrating so far (it kept me successfully from being productive
> instead I still fiddle around with these weird font settings :( ).
> ** (xfce4-session:3092): WARNING **: Unable to launch
> "/home/enrico/apps/xfce-svn/share/xfce4/xfconf-migration/xfdesktop-xfconf-migration.pl" (specified
> by autostart/xfconf-xfdesktop-migration-4.6.desktop): Kindprozess
> »/home/enrico/apps/xfce-svn/share/xfce4/xfconf-migration/xfdesktop-xfconf-migration.pl«
> konnte nicht ausgeführt werden (Keine Berechtigung)

Maybe start the script by hand and see what its output is?

  - Jannis
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20080710/fc0a7815/attachment.pgp>

More information about the Xfce4-dev mailing list