[Xfce4-commits] r29004 - in xfce4-mixer/trunk: . panel-plugin xfce4-mixer
Brian J. Tarricone
bjt23 at cornell.edu
Wed Dec 10 23:25:04 CET 2008
Just a few notes..
Jannis Pohlmann wrote:
> message = g_strdup_printf (_("Could not execute the command %s. "
> - "Perhaps you need to adjust the PATH variable."),
> + "Perhaps the PATH variable needs adjustment."),
This is a minor nitpick, but... probably a better phrasing would be
simply "Ensure that the PATH environment variable includes the location
of the command" (I don't like the last half of that, but the phrasing is
1. It notifies the user clearly that they may need to do something.
2. It is precise -- "variable" is ambiguous, "environment variable" is not.
3. It tells the user what kind of adjustment is necessary.
Of course, if they get to this point, the average user won't really have
a clue what to do anyway, no matter what the dialog says, so it might be
a moot point.
Maybe I wasn't really clear on the whole "avoid addressing the user
directly" thing. It's more about not using "you" sentences and being a
little more target-neutral. If the user needs to take some action to
proceed, you should make it clear that the user has to do something.
Saying "Perhaps PATH needs adjustment" doesn't do that -- the user could
think "oh, maybe the programmer did something wrong" or "oh, maybe my
sysadmin needs to fix this" or whatever. Using verbs like "ensure" puts
the ball in the user's court for the next step without pointing a big
fat finger at them like "You need to fix PATH" would do.
> - xfce_err (_("GStreamer was unable to detect any sound cards on your system. "
> - "You might be missing sound system specific GStreamer packages. "
> - "It might as well be a permission problem."));
> + xfce_err (_("GStreamer was unable to detect any sound cards. "
> + "Some sound system specific GStreamer packages may "
> + "be missing. It may also be a permission problem."));
"Permissions" should be plural here.
Also I'd discourage the use of xfce_err() (perhaps we should deprecate
it) as it doesn't produce the usual bolded primary text / normal
secondary text type of dialog.
> - xfce_titled_dialog_set_subtitle (XFCE_TITLED_DIALOG (dialog), _("Please select which mixer track should be used by the plugin"));
> + xfce_titled_dialog_set_subtitle (XFCE_TITLED_DIALOG (dialog), _("Select which mixer track should be used by the plugin"));
I already made a note about this on Bugzilla but for consistency: don't
use XfceTitledDialog subtitles as a substitute for normal dialog text.
The subtitle should serve as a description of what the dialog does or is
for. Put another way, the user should still know what to do if the
subtitle were to disappear. If you need to prompt the user for
something, use a normal GtkLabel in the body of the dialog.
XfceTitledDialog may not even be appropriate, depending.
> - xfce_heading_set_subtitle (XFCE_HEADING (heading), _("Configure your sound card(s) and control the volume of selected tracks"));
> + xfce_heading_set_subtitle (XFCE_HEADING (heading), _("Configure sound card(s) and control the volume of selected tracks"));
This would be an example of the correct usage for the dialog subtitle ^_^.
> - gtk_label_set_markup (GTK_LABEL (label2), _("No controls are marked as visible. Please open the <span size='large'><b>Select Controls</b></span> dialog to select some."));
> + gtk_label_set_markup (GTK_LABEL (label2), _("No controls are marked as visible. Open the <span size='large'><b>Select Controls</b></span> dialog to select some."));
There's no reason to remove the "please" here. Being polite never
hurts, as long as it's not overused. More a personal style thing, I guess.
More information about the Xfce4-dev