Xfce 4.4.1 on Monday 09-apr [WAS Re: Xfce 4.4.1 ?]

Brian J. Tarricone bjt23 at cornell.edu
Sat Apr 7 19:24:03 CEST 2007

Hash: SHA1

On Sat, 7 Apr 2007 11:52:59 +0200 Oliver Lehmann wrote:

> Brian J. Tarricone wrote:
> > Then what's the problem?  We're not changing the lib numbering.  The
> > major/minor *library* version will remain the same; just the package
> > version will change.  As long as the libutil 4.4.1 Xubuntu package
> > hits your repository by the time xfdesktop 4.4.1 does, there's no
> > problem.
> Not changing the library major/minor number, but depending on the
> lateste package containing the lib is baaaad. Many packaging systems
> are only depending on library version numbers.

What packaging systems?  Any package manager that can't depend on a
particular package version is broken, IMHO.  And, as I mentioned in a
previous mail, it's not like I'm doing something unprecedented.  Thunar
depends on gtk 2.6.4.  *Every* Xfce release in the 4.0 and 4.2 series
used this method for its configure-time dependencies.  If there was a
problem, it would have showed up sometime in the past 3+ years.

> When the package now
> depends on the library number. The dependency is already resolved by
> 4.4.0. But then your configure script wants 4.4.1 -> baaad.
> When you depend on a specific version of a lib you should imho also
> bump the lib.

No, the library version is based on the API/ABI, not bugfixes.

> Otherwise as stated in the first mail - when no API
> changed you shouldn't depend on the latest lib... it will also work
> with an earlier version of the lib. Otherwise all this makes no sense
> and you can break the API where you want - when you always depend on
> the latest library versions - preserving the API makes no sense at
> all. Or?

I don't see it that way.  The two issues are orthogonal.  The library
version indicates API/ABI stability, and the package version is just a
way of keeping track of successive releases.  Most people build some
kind of API/ABI version into the package version for convenience, though
that's of course not strictly necessary.  Depending on a particular
package version can have either purpose (or both purposes): making sure
the package uses a version with a compatible API/ABI, and making sure
the package uses a version that does not contain critical bugs.

At any rate, I'm getting rather tired of repeating myself over and
over.  I've made my decision, and I see nothing in any replies to
convince me to change it.  I consider this issue closed.


Version: GnuPG v2.0.3 (GNU/Linux)


More information about the Xfce4-dev mailing list