Xffm and Samba 3.014a and Japanese

Daichi Kawahata daichi.k at aioros.ocn.ne.jp
Fri May 27 11:08:23 CEST 2005

On Thu, 26 May 2005 13:06:00 -0500
Edscott Wilson Garcia wrote:

> > Ah, it also fixes start-up errors on xfmime-edit, which claims
> > there're missing icons in icon set. So according to xfmime-edit,
> > there're still skull icons (pirate.png) at
> >
> >         stock
> >           m-font.svg  <- this one
> >           m-lock.svg  <- this one
> >           [...]
> >           stock_dnd_multiple.svg <- this one
> I cannot find anything wrong with these icons. Are they installed
> where they are supposed to? If you view the directory where they
> live with xffm are they previewed properly?

They aren't still displayed correctly even on your latest change, you
can see at attached images. What I'm wondering is these SVG icons were
displayed correctly with the other apps, so icon itself would be valid.

However it was ringing a bell when I had seen the following outputs and
attached stack trace log (removing & recreating Rodent.48.cache.dbh
didn't work, also it wasn't entire crash),

    TRACE[icon-module-theme.i:739] get_cache_path(): using cache: \

    TRACE[icon-module-theme.i:666] find_icon_path_priv(): \
     cache miss for key m-lock (3165463179), cache will be \
     regenerated soon.
    TRACE[icon-module-theme.i:666] find_icon_path_priv(): \
     cache miss for key m-font (3165284783), cache will be \
     regenerated soon.
    TRACE[icon-module-theme.i:666] find_icon_path_priv(): \
     cache miss for key stock_dnd_multiple (3886323230), \
     cache will be regenerated soon.

In fact, I've been having a problem with svg_loader.so (librsvg), which
have been causing nasty segfault :-( it had been already reported at


In consequence, I couldn't have SVG loader in ../gtk-2.0/2.4.0/loaders,
and with these matters, I'm convinced that it's nothing to do with xffm.

> > I see, also have a question that is that monitoring concerned with
> > response rate ? it sounds odd but I've noticed when I clicked
> > directory icon, there costs measurable time in between next displaying
> > (my machine isn't enough fast, because of).
> If the reload of a directory takes more than 2 seconds, then will not be
> reloaded automatically whenever it changes. Instead you have to reload
> it manually. Probably should write to status line that the directory has
> changed so user will know it is not up to date.

Yes, message appears, please apply the patch also.

Index: POTFILES.in
--- POTFILES.in (revision 14558)
+++ POTFILES.in (working copy)
@@ -16,6 +16,7 @@

> > Then, on topic, what I've noticed in xfsamba4 is that it displays
> > anything in the viewing home directory as plain files, so I couldn't
> > change current directory anymore, I know it might be default behaviour
> > on my settings (and IRIX doesn't support smbfs, as a result, I was
> > claimed when I had tried to mount my home directory via this plugin)
> > in Samba, but is there any advice about that ?
> Seems like a bug. Use treeview gui and turn verbose options on. Then
> when you open your home directory, look at the output in the diagnostics
> window and cut+paste so I can see what is not interpreted right.

First of all, just after succeeded login, I saw Samba account password is
shown at status bar with plain ASCII ;) as for diagnostics, they are
just outputted on directory reading as follows, but probably it needs to
be increased log verbosity level on Samba side.

    Domain=[MOOSE] OS=[Unix] Server=[Samba 3.0.14a]

        Sharename       Type      Comment
        ---------       ----      -------
        IPC$            IPC       IPC Service (Samba Server)
        ADMIN$          IPC       IPC Service (Samba Server)
        dick            Disk      dick's Home Directories

        Server               Comment
        ---------            -------

        Workgroup            Master
        ---------            -------
        XFCE                 MOOSE

    XFSAMBA> smbclient //MOOSE/dick -c ls /*
    Domain=[MOOSE] OS=[Unix] Server=[Samba 3.0.14a]
      .                       D       0  Fri May 27 07:38:09 2005
      ..                      D       0  Wed Feb  5 19:35:07 2003
      .xt                    DH       0  Sun Mar 21 12:31:16 2004
      bin                     D       0  Mon May 16 18:05:20 2005
      src                     D       0  Sat Apr 30 21:03:40 2005

at present, it looks like an attached image (xfsamba4.png), I could
just see home directory but never change from there.

The last one, when I tried to generate API docs with gtkdoc 1.3, the
following errors were emitted in the doc/API,

    $ gmake      
    *** Scanning header files ***
    grep: ./xffm.types: No such file or directory
    *** Rebuilding template files ***
    cd . && gtkdoc-mktmpl --module=xffm
    Structure declaration '  struct polygon *next;
      struct polygon *previous;
    ' does not begin with struct [NAME] {
    gmake: *** [tmpl-build.stamp] Error 255

I'm bit interested in plugin for xffm ...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: xfmime-edit_skull-1.png
Type: image/png
Size: 7061 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20050527/04e19d3c/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xfmime-edit_skull-2.png
Type: image/png
Size: 4146 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20050527/04e19d3c/attachment-0001.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xfmime-edit_bt.log
Type: text/x-log
Size: 1956 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20050527/04e19d3c/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xfsamba4.png
Type: image/png
Size: 28412 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20050527/04e19d3c/attachment-0002.png>

More information about the Xfce4-dev mailing list