Build errors with Pyxfce and Xfc from SVN (revision 16828)

Brian J. Tarricone bjt23 at
Thu Aug 11 01:28:03 CEST 2005

Hash: SHA1

Myles Green wrote:
> On Wed, 2005-10-08 at 11:46 -0700, Brian J. Tarricone wrote:
>>This is kinda odd.  My guess is that you don't have a recent version
>>automake installed.  Xfce-related stuff requires 1.8 or higher (though
>>some of the packages may work sometimes with lower versions, this is
>>unintentional and unsupported).
>>A while ago I modified xfce4-dev-tools to first search for
>>then automake-1.9, then simply automake.  Most (recent?) Linux distros
>>will allow you to install several versions in parallel using that
> Hmm, according to dpkg -s I have several versions of automake installed
> on this system (running Debian unstable).
>  which automake
> /usr/bin/automake
>  ls -l /usr/bin/automake*
> lrwxrwxrwx  1 root root     26 Jul  9 09:15 /usr/bin/automake
> -> /etc/alternatives/automake
> -rwxr-xr-x  1 root root 199559 Feb  5  2005 /usr/bin/automake-1.4
> -rwxr-xr-x  1 root root 236925 Feb  5  2005 /usr/bin/automake-1.6
> -rwxr-xr-x  1 root root 270996 Feb  5  2005 /usr/bin/automake-1.7
> -rwxr-xr-x  1 root root 211025 Feb  5  2005 /usr/bin/automake-1.8
> -rwxr-xr-x  1 root root 221993 Jul 13 00:04 /usr/bin/automake-1.9

Well, from the output, it appears that it's simply running 'automake',
and not one of the versioned apps.  Checking what
/etc/alternatives/automake points to will solve that one (note that
aclocal needs to point to the correct version as well).  as usual
'automake --version' will tell you.  Unfortunately, you left out that
critical bit of information.

> I also have xfce4-dev-tools-4.3.0 installed.

That's difficult, since there's never been a public release of
xfce4-dev-tools ^_~.  Anyway, since you presumably installed them
yesterday via my script, I'd like to assume it's up to date.  However,
as I said, from your output it appears that 'automake' is being run,
which shouldn't be the case if 'automake-1.8' or 'automake-1.9' is
found.  Make sure you don't have an older copy of xfce4-dev-tools
installed somewhere earlier in your PATH.

Version: GnuPG v1.4.1 (MingW32)


More information about the Xfce4-dev mailing list