crashing apps

Mantas mantas at
Mon Mar 15 12:22:36 CET 2004

Sk, 2004-03-14 12:49, Brian J. Tarricone rašė: 
> remember a week or 2 ago when i mentioned that some apps being launched 
> by the xfdesktop menu were immediately segfaulting?  danny followed up, 
> saying that even with a mini test program using xfce_exec(), he could 
> reproduce the crashing, or he sometimes ended up with apps hanging.  
> i've talked to a couple people in #xfce with one or both problems.
> in moving all the menu code into a gmodule, i rewrote large portions of 
> it (iirc, the only thing left that i didn't touch is the menuspec 
> stuff).  the crashes are still there.  edscott mentioned using electric 
> fence to try to catch any possible illegal memory references, but it 
> didn't come up with anything.
> here's the weird part.  for me, the only two apps that crash (so far) 
> from the menu are gedit and gnome-terminal. _but_, they only crash 
> sometimes.  if i have a gnome-terminal or gedit window already open 
> (launched from eterm or the panel), and i try to run either from the 
> menu, they load fine.  this somewhat makes sense, since i believe both 
> of them first check for running instances and have the already-running 
> instance spawn another window.  now the odd thing.  if gedit is open, 
> and i run gnome-terminal from the menu, gnome-terminal runs 
> successfully.  (the reverse also works.)  this is really bizarre.
> mantaz (from #xfce) said he's seeing danny's problem of apps hanging 
> without starting...  this doesn't appear to be just xfdesktop either.  
> jimmiejaz said gaim crashes if he runs it from the panel, but not from a 
> terminal.

now i can describe the problem.
I logged in and started the gnome blackjack game and its doesn't appear.
ps aux writes:

1009 ?        S      0:01 xfwm4 --daemon --sm-client-id
2370 ?        S      0:00 blackjack
2371 ?        Z      0:00 [blackjack] <defunct>
2372 ?        S      0:00 /usr/lib/gconf2/gconfd-2 14
2379 ?        S      0:00 xterm -title Terminal

i killed 2370 process (see above) and then tried to rerun blackjack and
then it starts normally.

I also have a problem when i run mozilla-firefox from menu.
when i click on hyperlink to pdf file firefox closes without any errors.
If im running programs from console there are no bugs.

> the one constant (so far) seems to be that running things from xfrun4 
> works fine.
> i'm not sure what to do.  i'm tempted to just ignore it for the time 
> being, in the hopes that it will magically fix itself when something 
> else gets fixed/changes.  but it really bothers me...
>     -brian
> _______________________________________________
> Xfce4-dev mailing list
> Xfce4-dev at



More information about the Xfce4-dev mailing list