rpm creation problems

Jasper Huijsmans jasper at moongroup.com
Sun Jun 1 19:25:31 CEST 2003


On Sun, 1 Jun 2003 16:30:07 +0100
Gavin Jones <roggtemp at yahoo.co.uk> wrote:

> Hello Jasper,
> Its a fresh cvs checkout [16:00 GMT] .
> I'm quite happy to test whenever you want :)

You're a great help. Let's get this baby to build correctly ;-)

> xfce-mcs-plugins
> -----------------
> tr:
> msgmerge: tr.old.po: warning: Charset missing in header.
>                               Message conversion to user's charset
>                               will not work.
> tr.old.po:9:2: parse error
> tr.old.po:9: keyword "tr" unknown
> tr.old.po:9: keyword "po" unknown
> msgmerge: found 3 fatal errors
> msgmerge for tr.gmo failed!

I tried to fix this one. Seems to work. 

> xfce-utils
> -----------
> config.status: creating xfce4-about/INFO.html.ca
> config.status: error: cannot find input file:
> xfce4-about/INFO.html.ca.in error: Bad exit status from
> /var/tmp/rpm-tmp.29799 (%build)
> RPM build errors:
>     Bad exit status from /var/tmp/rpm-tmp.29799 (%build)
> make: *** [rpm] Error 1

I don't understand this. 'DESTDIR=$HOME/src make distcheck' works fine
for me, which means the above file must be present. Do you have the
file? and when you do 'make dist' is it included in the tarball?

I did fix another po-file issue, so you could try updating anyway.

> xfdesktop
> ---------
> Making all in images
> make[5]: Entering directory
> `/usr/src/redhat/BUILD/xfdesktop-3.90/doc/C/images' make[5]: *** No
> rule to make target `root_menu2.png', needed by `all-am'.  Stop.

Same as above, distcheck works for me, which again means the file must
be present. Can you check if you have it?

> xffm
> ----------
> make[1]: Entering directory `/usr/src/xfce4/xfce-devel/xffm'
> rm -rf .libs _libs
> rm -f *.lo
> make[1]: Leaving directory `/usr/src/xfce4/xfce-devel/xffm'
> make: *** No rule to make target `acconfig.h', needed by `distdir'. 
> Stop.

hmm, you reported that earlier and then I saw it too. But I fixed that
(yesterday I believe) and at least now it works for me. I'm beginning to
think you may have some older versions lying around ...

> xfwm
> -----------
> Making all in images
> make[5]: Entering directory
> `/usr/src/redhat/BUILD/xfwm4-0.90/doc/C/images' make[5]: *** No rule
> to make target `decoration_style.png', needed by `all-am'.  Stop.

Same as the others, distcheck works for me. Please check if you have
this file.

> All other xfce-devel built OK.

Ok, great. So, the question is, do you have old versions lying around --
perhaps in the rpm build dir, I don't know -- or does anyone else see
these problems too?

I really would like to get this working. Being able to build rpms is a
very good feature to have.


More information about the Xfce4-dev mailing list