[PROBLEM] libxfcegui4 creating libraries with strange [SO]names

Jasper Huijsmans jasper at moongroup.com
Sat Aug 30 15:36:31 CEST 2003

Op za 30-08-2003, om 13:54 schreef Martin Loschwitz:
> Hi folks,
> while building Debian Packages for libxfcegui4, I ran into an odd looking
> problem: with "./configure --prefix=/usr --enable-xinerama", it creates
> libraries like the following: 
> -rw-r--r-- root/root    208624 2003-08-29 23:30:32 ./usr/lib/libxfcegui4.so.0.1.1
> This is obviously wrong, since it is supposed to be ./usr/lib/libxfcegui4.so.1.1.1,
> isn't it?
> I ran into further strace effects while playing with LIBXFCEGUI4_VERINFO:
> LIBXFCEGUI4_VERINFO=1:1:1 results in libfoo.so.0.1.1
> LIBXFCEGUI4_VERINFO=1:1:0 results in libfoo.so.1.0.1
> LIBXFCEGUI4_VERINFO=1:0:1 results in libsoo.so.0.1.0
> I don't know whether the patch attached is correct but it is what we will be
> using for the debs for now.
> Thanks in advance,

Grr, I seriously dislike libtool ... Thanks for pointing it out. Perhaps
it should be bumped to 1:2:0, I'll have a look later today.


More information about the Xfce4-dev mailing list