Problem with compilling XFCE

Olivier Fourdan fourdan at
Mon Oct 14 14:32:07 CEST 2002


glib-2.x/gtk+-2.x and glib-1.2.x/gtk+-1.2.x aren't compatible in any way (ie
it's not source compatible nor binary compatible)

You need glib-2.0.x + pango-1.0.x + atk-1.0.x + gtk+-2.0.x (all packages that
make gtk+-2.0, in a nutshell)

Since most gtk programs out there haven't been ported yet, you'll need probably
both gtk+-1.2 and gtk+-2.0 installed. Note that rh8.0 already comes with gtk-1.2
and gtk+-2.0 (but what you might be missing are the devel packages, red hat, in
its default install, usually doesn't install the required headers to build the
programs but just the binary libs to run precompiled programs)

To check that you have the correct libs, use pkg-config :


$ pkg-config gtk+-2.0 --modversion
$ pkg-config glib-2.0 --modversion
$ pkg-config pango --modversion
$ pkg-config atk --modversion


Quoting Karol <karol at>:

> Today I download files from CVS (xfce-devel/xfce4). I tried compile it
> using RedHat 8.0. Unfortunatelly I have installed two RPM's one with
> glib-2.0 and another with glib glib-1.2. Every time I try to run
> script
> "configure" I got error that my glib version is lower than 2.0
> Pkg-config see only the older library.
> Is there any solution for my problem?
> Thanks
> -- 
> Karol <karol at>
> _______________________________________________
> Xfce4-dev mailing list
> Xfce4-dev at

XFce is a lightweight  desktop  environment  for  various *NIX systems. 
Designed for productivity,  it loads  and  executes  applications fast,
while conserving  system resources. XFce is all free software, released
under GNU General Public License.    Available from

More information about the Xfce4-dev mailing list