Launcher problem

Renaud (Ron) OLGIATI renaud at
Tue Jun 30 13:12:29 CEST 2020

On Tue, 30 Jun 2020 12:08:35 +0200
"jEsuSdA 8)" <listas at> wrote:

> El 29/6/20 a las 17:33, Renaud (Ron) OLGIATI escribió:
> > I have been having a problem with LibreCAD, the font size used for the menus, the menu bar, and the status bar are so small that the program is unusable as it is.
> > Found a solution which is to launch it from the CLI with xrandr --dpi 96 && librecad, which solves the font size problem.
> > So I tried to put that in my LibreCAD launcher, replacing librecad %F with /usr/bin/xrandr --dpi 96 && librecad %F
> > Sadly, it does not work, and librecad does not start.
> > Am I missing something ?

> May be you can create a script "" with the content:
> 8<----------
> #!/bin/bash
> /usr/bin/xrandr --dpi 96 && librecad $1
> exit
> 8<----------
> And then, you can change the launcher to call it instead.
> I use this method with some launchers that does not work at all if the 
> command line has several parameters.

Thank you for the pointer.

Tried this, running ~/bin/librecad from the CLI works beautifully, but if I put ~/bin/librecad %F in the launcher it gives me an error window , 
Failed to execute ~/bin/librecad %F
Failed to execute child process "~/bin/librecad" (no such file or directory)

and if I put /home/ron/bin/librecad $1 in the launcher  LibreCAD starts with the unreadable small font.

? ? ? ?
                 Only after the last river has been poisoned,
                 Only after the last tree has been cut down,
                  Only after the last fish has been caught,
           Only then will you find out that money Cannot Be Eaten.
                                                  -- Cree Prophecy
                   -- --

More information about the Xfce mailing list