adapted $PATH not available for GUI

houghi at houghi at
Sun Mar 16 12:17:34 CET 2014

I am running Debian and XFCE 4.10 that starts with lightdm.
I am somehow unable to add $HOME/bin to all users in a simple way for

**This is NOT about if this is a good idea¹**

What I do now is put a LOT of file that I rather have in ~/bin into
/usr/local/bin and also use full path to /home/user/bin for as many
purposes as possible.

I have tried adding 'PATH="$HOME/bin:$PATH' into the following files:

Obviously I have added it to ~/.bashrc, so I can have it at least when I
want to run it from a terminal, but I can not have it when I use e.g.
`xfce4-appfinder -cr` which is linked to <ALT>-<F2>.

So there must be some other file that sets PATH. A grep shows me 297 files
that contain PATH. (238 if I remove the /etc/rc?.d/K* files.

My question:
Why are none of the files I have tried read?
What file must I edit, so ALL users will be able to be using $PATH?

What I understand is that .profile should be read, but isn't or it is
ignored after starting the GUI. What could be the reason and where can I
start looking to solve this.

If need be, I can go upstream (i.e. debian) but then I first need to know
WHY this is happening. When I used openSUSE 5.4 till 13.1, this worked by
default, so I know it is possible.

¹I am aware of the advantages and disadvatages of adding SHOME/bin to
$PATH and also what it means to add it at the beginning or at the end.
This is not about ones person way of working and thinking compared to the
others. This is about why settings are not being read and it does not work
as _I_ want it to work.

  We all came out to Montreux           Frank Zappa and the Mothers
 On the Lake Geneva shoreline           Were at the best place around
To make records with a mobile           But some stupid with a flare gun
     We didn't have much time           Burned the place to the ground

More information about the Xfce mailing list