ANNOUNCE: xfdashboard 0.1.2 released
subscript at free.fr
Sun Jan 26 16:02:59 CET 2014
On Sun, 26 Jan 2014 01:44:27 +0100 Stephan Haller <nomad at froevel.de> wrote:
> Hi wwp,
> Am Sonntag, den 26.01.2014, 01:19 +0100 schrieb wwp:
> > > All dependencies should be fulfilled by a normal installation of Xfce
> > > 4.10. The only exception is clutter of version 0.12.0 or higher. But
> > > here is the full list of dependencies:
> > >
> > > libwnck >= 2.30
> > > clutter >= 1.12
> > > glib >= 2.30.3
> > > gio >= 2.30.3
> > > gio-unix-2.0 >= 2.30.3
> > > xfconf >= 4.10.0
> > > dbus-glib >= 0.98
> > > garcon >= 0.2.0
> > >
> > > ... and the dependencies of these libraries of course ;)
> > I see, I know that Xfce 4.10 requires Glib/Gtk+ 2.2x but many Xfce apps
> > or plugins have requirement for 2.30 mini, that's something I never
> > understood completely.
> A litte bit offtopic ;) and I'm afraid that I cannot enlighten
> you :( But I can explain how I determined this requirements.
> When I started to develop I thought: "Will all distribution use the same
> version like my distribution (Gentoo)?" So I looked at all distributions
> I think they are the "main distributions" like Fedora, Ubuntu, openSuSE,
> Debian and of course Gentoo and that's are the lowest versions of each
> library they have in common. Maybe other developer do it similar.
You seem to exclude all long-term support version of distros that ship
Gtk+ 2.2x (centos 6, deb6, ubuntu 10.04), but I get your point and can
live with it, I won't complain. Thanks for these explanations!
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 198 bytes
Desc: not available
More information about the Xfce