ANNOUNCE: xfce4-weather-plugin 0.8.1 released

Guido Berhoerster gber at
Mon Aug 6 15:11:45 CEST 2012

* Harald Judt <h.judt at> [2012-08-06 14:50]:
> Am 06.08.2012 14:26, schrieb Guido Berhoerster:
> >* Liviu Andronic <landronimirc at> [2012-08-06 14:17]:
> >>On Mon, Aug 6, 2012 at 1:48 PM, Harald Judt <h.judt at> wrote:
> >>>xfce4-weather-plugin 0.8.1 is now available for download from
> >>>
> >>[..]
> >>
> >>>- Bump minimum requirements to XFCE-4.6.
> >>>
> >>Does this mean that the latest release is now compatible with 4.6? I
> >>tried to configure it against Xfce 4.6 but it failed:
> >>checking for libxfce4ui-1 >= 4.7.0... not found
> >>*** The required package libxfce4ui-1 was not found on your system.
> >>*** Please install libxfce4ui-1 (atleast version 4.7.0) or adjust
> >>*** the PKG_CONFIG_PATH environment variable if you
> >>*** installed the package in a nonstandard prefix so that
> >>*** pkg-config is able to find it.
> >>>/home/liv/Build/xfce4-weather-plugin-0.8.1/configure (28151) returned '1'
> >>
> >>I don't think that libxfce4ui is available for 4.6. Did I
> >>misunderstand something?
> >
> >No, the requirements are wrong. xfce4-weather-plugin is built as
> >a module and uses libxfce4ui, both are only available on Xfce >=
> >4.8 so the minimum requirements should be raised to that.
> Ok. Then I got it wrong again, sorry. I thought it might be
> compatible with XFCE-4.6, but because of the libxfce4ui port and the
> module it certainly cannot be anymore. I will raise the minimum
> requirements to Xfce-4.8 for the next version.
> Can someone please clarify which versions of xfce a panel plugin
> *has* to support? Are there any rules? The wiki page only tells you
> the dependencies for Xfce-4.{6,8,10}.
> I'm not feeling like adding support for Xfce-4.6 back in. Ditching
> support for Xfce-4.6 means I can throw away some more deprecated
> code too, e.g. old tooltips code.

Only the last release of the Xfce core components is being
maintained. Since there haven't been significant changes for
panel plugins since 4.8 I think it is reasonable to support 4.8
and 4.10. That's what those panel plugins that are still being
maintained do anyway.

Unfortunately I can't get it to display an actual forcast for any
location in my vicinity, even when selecting major cities like
Berlin or Hamburg it only displays "Short-term forecast data

The plugin also immediately crashes when opening the "Forecast"
window, I've filed a bug with a backtrace atttached at
Guido Berhoerster

More information about the Xfce mailing list