Problem when compiling xfce4-notes-plugin

Mike Massonnet mmassonnet at
Sun Dec 19 20:16:59 CET 2010

2010/12/19 Cristian Marchi <cri.penta at>
> Thanks Nick. Your suggested patch in xfce bugzilla [1] worked. Now I'm stuck during make with this error:
         ^^^^^ Mike

Good that it works, I'll push the patch.

> Package `libxfcegui4-1.0' not found in specified Vala API directories or GObject-Introspection GIR directories
> I get the same error also with vala 0.10. I've compiled libxfcegui4 from git in /usr/local/ and "" doesn't gives me any error.
> I'm just trying to compile the notes plugin to test the Italian translation.

Alright, there was a bug lying around when compiling against
Xfce4-vala 4.7. Fixed it in the notes plugin, I tested and it works
fine now.

NB: once compiled you can executed both the program and the settings
dialog without installing them:
make -C po install
./src/xfce4-notes &
./src/xfce4-notes-settings &

> Thanks for the help.
> Cristian

You welcome,

More information about the Xfce mailing list