xfce4-session not restoring position. Bug or can I run KDE's session manager?

Sean Reifschneider jafo at tummy.com
Sun Dec 5 11:40:16 CET 2010

Hash: SHA1

On 12/05/2010 01:52 AM, Hans Georg Schaathun wrote:
> FWIW, for me it worked (for xterm) out of the box.  So it should work,
> but I never needed to figure out how or why ...
> (I am using Ubuntu 10.10 with its standard xfce build.)

That's really odd, because I'm also using Maverick and the standard build,
and once you said this I tried logging out and back in and my xterm and
chromium locations were successfully restored.  But previously, several
times, they weren't getting saved.  Probably over 5 or more logouts.

I think what might have been happening was that somehow the wrong logout
button was in my panel?  Because before the logout button was a o with a |
in it, you know the international power-button logo.  Now it's a green guy
running through a white door.

The thing that seems to have changed was that earlier I logged in and my
panel was entirely gone.  I logged out and back in, and it was still gone.
So I manually ran "xfce4-panel" and my panel came back, though looked
slightly different in color, but it still had my clock customizations, and
the little mouse next to "Applications"...

But, everything I clicked was making noise through my speakers, drums and
stuff.  So something obviously changed.  If I wanted drums when I clicked
buttons, I'd use Rock Band for my pointing device.  :-)

I really don't know what changed, but obviously some things changed and at
that point xterms are being saved.

So, thanks for whatever you did.  Must be your mojo.  :-)

Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Xfce mailing list