Losing mouse

Robert traveling08 at cox.net
Wed Jun 17 15:40:07 CEST 2009

On Tue, 16 Jun 2009 11:08:41 -0400
Gerard <gesbbb at yahoo.com> wrote:

> I just installed FreeBSD-7.2 on a new PC. I then proceeded to install
> all the prerequisite programs and finally XFCE4.
> Specifically:
> Xfce 4 Desktop Environment
> version 4.6.1 (Xfce 4.6)
> The problem is that for no apparent reason and at random times, the
> mouse pointer disappears. If I move the invisible mouse around the
> screen, icons will respond. However, I cannot physically see the mouse
> cursor.
> I have tried shutting down Xfce and restarting it to no avail. The
> only way I can get the mouse pointer back is to do a reboot of the PC.
> I have no idea what to look for so I cannot figure out how to file a
> bug report on it.
> Has anyone else experienced this phenomena?
Hello Gerard

And here I thought I was alone in the world. I too run FreeBSD and
XFCE4 and am experiencing this problem. I started this thread las


I tried different window managers with the same problem but only while
using "nv" as the video driver. Switching to VESA, the problem does not
happen. I am running the AMD64 version and the above thread gives
details of my hardware.

I have convinced myself this is some conflict between my hardware and
the "nv" driver, so 99% of the time I stay in CLI. This system is used
mainly as a file server but every now and then I will have to "startx". 

I am using a KVM switch so the VESA driver is more of a PITA than it
is worth because of the different screen positions.

I am curious as to what your hardware is.



More information about the Xfce mailing list