xfce4-mount plugin fails to umount device mounted to directory with spaces

Sergei Danilov geonix at tut.by
Sun Mar 4 04:24:52 CET 2007

Hi Fabian, 
I missed this email in my inbox. Try to answer today

On Wed, 28 Feb 2007 20:44:39 +0100 (CET)
timystery at arcor.de wrote:

> You might want to run xfce4-panel from a terminal and view the
> debugging output if it prints some useful information. As a starting
> point, I will concentrate on the code which reads mtab.
I compiled the plugin with debug option. and executed the xfce4-panel
from command line. I did not found any useful information about mount
plugin there, when I did some mount actions.

> For y complete understanding:
> - your sudo pmount and sudo pumount from the last e-mail worked in a
> shell?
Yes, sudo pmount works in the shell as a single command (without
I attached logs here: see
system does not write anything in the fstab here, just in the mtab
I attached a small peace of log here :see pmount_pumount_from_shell.txt
> - you mounted with ivman && sudo pmount from a terminal and the
> mount-plugin did not show the device afterwards?
1 Not from terminal directly: ivman daemon automatically executes
predefined pmount dev label from config (according to the messages log
pmount command looks identically pmount from shel directly)
And YES, after execution of pmount both from ivman or shell, plugin
does not show the device in the GUI window.
2. I tried to use mount command from the shell: sudo mount /dev/sdb
"/media/MP3 Muvo2", but also without success , plugin shows nothing
about my device in the view. So the problem is not he "pmount" one, but
most probably the device type.
3. Also I tried to use different mount locations like "/media/MP3 Muvo2"
and "/media/sdb" , neither of them made the device visible fro
xfce mount plugin.So problem is not the mount-point ptoblem , like
spaces, rights or smth else

I stored the hal info about my MP3 device in the 
'USB_Device_Info.txt', my be it will be useful.
But in general the device mounted as a simple flash (data storage

Have a nice Sunday.
Best regards, 
Regards Sergei
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: pmount_pumount_from_shell.txt
URL: <http://mail.xfce.org/pipermail/xfce/attachments/20070304/1ab83a8d/attachment.txt>

More information about the Xfce mailing list