Enable reboot/shutdown (newbie question?)

Nathan Elliott nelliott at gci.com
Sat Mar 5 01:01:19 CET 2005

I wonder if I've screwed up somewhere...this answer seemed to make perfect

I downloaded the xfce4-session-4.2.0 tar.bz2 package, and configured it

"./configure --with-shutdown-style=auto"

>From config.log:

configure:24893: checking what shutdown style should be used
configure:24903: result: sudo

Everything built fine, so I did "make install", exited and restarted X...but
the shutdown and reboot options were still greyed out.

I ran updatedb and then 'locate xfsm-shutdown-helper' and found the old
version still in /usr/lib/ and the new version in /usr/local/libexec/ - so I
manually copied the new version to /usr/lib/ , did init 3, init 5 and still
things don't work.

If I run xfsm-shutdown-helper from a prompt I get:  XFSM_SUDO_DONE  but
nothing ever happens.

Any more ideas?  Thanks for all the help!

-----Original Message-----
From: Nathan Elliott 
Sent: Thursday, March 03, 2005 6:43 PM
To: 'xfce at xfce.org'
Subject: Enable reboot/shutdown (newbie question?)

I read the manual, and searched the online mailing list archives...and
either I'm the only dope with this problem, or I'm just missing the obvious.

I'm running XFCE 4.2 installed via RPMs from http://www.eslrahc.com/ on
Mandrake 10.1

Everything works great, and I love it!!!...Except I can't get the darned
shutdown/reboot options enabled.

Snippet from my /etc/sudoers file:

nelliott localhost=/usr/local/libexec/xfsm-shutdown-helper

As you might guess, I can sudo anything I want on the system.  Still, the
little reboot and shutdown options are un-selectable to me.  =(

The binary file "xfsm-shutdown-helper" actually installed itself to
/usr/lib, so first I tried adding that path to my sudoers file.  Next I
created a symlink to the file in /usr/local/libexec...

Please help!??


Message: 10
Date: Fri, 4 Mar 2005 02:00:25 -0600
From: Thetargos <thetargos at gmail.com>
Subject: Re: Enable reboot/shutdown (newbie question?)
To: XFCE general discussion list <xfce at xfce.org>
Message-ID: <9f2d9fa8050304000066f85f78 at mail.gmail.com>
Content-Type: text/plain; charset=US-ASCII

Did you also install the xfce-session packages?


Yes, xfce-session is installed.  For fun I installed XFCE 4.2 on a second
machine, and I have the same problem there.  Any other cool ideas?

I wildly theorized that xfsm-shutdown-helper wasn't in my path, so I copied
it to /usr/X11R6/bin, this didn't help matters at all either.


Message: 3
Date: Fri, 04 Mar 2005 17:47:48 +0100
From: KUTYLA Peggy <peggy.kutyla at laposte.net>
Subject: Re: Enable reboot/shutdown (newbie question?)
To: XFCE general discussion list <xfce at xfce.org>
Message-ID: <1109954868.3784.3.camel at localhost>
Content-Type: text/plain; charset=iso-8859-15

Le vendredi 04 mars 2005 à 17:43 +0100, KUTYLA Peggy a écrit :
> Le vendredi 04 mars 2005 à 02:00 -0600, Thetargos a écrit :
> > Did you also install the xfce-session packages?
> Hi,
> look at this thread.

Peggy Kutyla - peggy.kutyla at laposte.net
Linux Registered User 328488

More information about the Xfce mailing list