Missing icons on the settings dialog's buttons.

Mark Tucker mark at tucker.net
Sat Oct 30 14:24:19 CEST 2004

Hash: SHA1

| Ok, could someone who has this problem try to run the following command
| (as root):
|  # gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
| And see if that solves the icon problems.

Interesting.  On my Slackware machine at home running
gdk-pixbuf-query-loaders produces the expected output (well, mostly) but
ends with the following error:

g_module_open() failed for /usr/lib/gtk-2.0/2.4.0/loaders/svg_loader.so:
libcroco.so.2: cannot open shared object file: No such file or directory

I did some searching and found that this libcroco.so is found in the
package libcroco-0.5.1-i486-1.tgz which part of Slackware's gnome install.

I installed the libcroco package and now gdk-pixbuf-query-loaders runs
without error.  I recereated the file /etc/gtk-2.0/gdk-pixbuf.loaders
but diff shows no difference between the original and the newly created
file except for the order of one of the order of a couple of the
entries.  Still no improvement in the icons on the settings manager.  I
have not recompiled my slackware package so I don't know if that will
fix things or not.

Again, one of my slackware machines at work has gnome installed and
these icons are visible on that machine.  The xfce package was created
on home home machine (without gnome installed).  I hope xfce isn't going
to become dependent on gnome.  A big part of the reason I run xfce is
that I loathe gnome and it's 10,000 library dependencies.

Version: GnuPG v1.2.4 (GNU/Linux)


More information about the Xfce mailing list