Command won't execute in launcher

Jack Kern jack_kern at
Mon May 17 04:52:34 CEST 2004

Jack Kern wrote:

> Brett I. Holcomb wrote:
>> I have a command
>> xyz arg1 "arg2with spaces"
>> that works perfectly from the command line.  When I set up a launcher 
>> with this command and tell it to run in terminal all I get is a quick 
>> flash like a terminal window opened and then closed.  I've tried 
>> various combinations of quoting (single, double, use \ to mark the 
>> space) and tried exec xzy arg1 "arg2with spaces" and nothing works. 
>> Any ideas on how to make this work?
> man xterm
>       -hold   Turn  on  the  hold  resource, i.e., xterm will not 
> immediately
>               destroy its window when the shell command completes.   
> It  will
>               wait  until you use the window manager to destroy/kill 
> the win-
>               dow, or if you use the menu entries that send a  
> signal,  e.g.,
>               HUP or KILL.
> Perhaps for the launcher command, like:
>       xterm -h -e xzy arg1 "arg2with spaces"

Oops, needs "-hold":

        xterm -hold -e xzy arg1 "arg2with spaces"

More information about the Xfce mailing list