can't stop xftaskbar from loading

Paul M. Bucalo linuxuser at
Sun May 2 01:53:14 CEST 2004

On Sat, 2004-05-01 at 19:35, Andrew Conkling wrote:
> On Sat, 2004-05-01 at 19:25 -0400, Paul M. Bucalo wrote:
> > Honestly, everything works fine except that I can't alter which XFce
> > modules load! Currently, I have both the taskbar and iconbox loading. I
> > have edited out the taskbar in every place I can think of it could be
> > in, and still the taskbar comes up!
> > 
> > On this system, I have calls to load the modules in:
> > 
> > /etc/xfce4/default.session
> > /etc/xfce4/xinitrc
> > /etc/xfce4/xinitrc.xfce4-session
> > 
> > I have tried:
> > 
> > 'cp /etc/xfce4/xinitrc ~/.xfce/xinitrc'
> > 'cp /etc/xfce4/xinitrc ~/.xinitrc'
> > 'cp /etc/xfce4/xinitrc ~/.xsession'
> > 
> > None of these have worked, either.
> I had similar problems for a long time (my particular issue was stopping
> the iconbox) and then I finally figured it out: I simply had to make my
> xinitrc executable.  I guess in the absence of that, it had been
> defaulting to the global file.

On my FC1 laptop, the files mentioned above are not executable, and yet
I am able to modify them with expected results. I went ahead and made
them executable on the RH 9 box, but still no difference. 

>   You may try adding a flag at the
> beginning of your global xinitrc (or your user one) to let you know
> which is successfully running.  Maybe a `touch ~/xfce-success` or
> something?

Tried that on both global files that actually call up the modules:
'default-session' and 'xinitrc'. 'xfce-success' was never created in
either user home or root.

> Hopefully, for sake of your sanity, this is a real issue and not
> something this silly, but you never know...! :)

It wouldn't be the first time that I temporarily lost my sanity over
something really stupid, but in this case, I think I am missing
something not obvious to me. I am still wondering about the use of
session-manager, but then, it still has to call the modules from a
script. Where's that magical script? I haven't any local, just global.
And using local didn't make a difference. Double-ARGH!

Thanks for you help. If you think of anything else, let me know?
Otherwise, I will try again tomorrow morning.


More information about the Xfce mailing list