no AA fonts in XFce4

Joost Kremers joostkremers at
Wed Jan 21 01:03:55 CET 2004

hi olivier,

thanks for the quick reply. unfortunately, setting GDK_USE_XFT to 1 does
not solve the problem. it does get rid of messages like this one, though:

** (xfdesktop:31284): CRITICAL **: file utf8.c: line 34
   (utf8_string_remove_controls): assertion `str != NULL' failed

i get similar messages from xfce-mcs-manager and xftaskbar4 if GDK_USE_XFT
is unset.

i tried recompiling pango (v1.2.5), but still no go. configure does report
that FreeType, X and Xft will be the available backends, but i'm not sure
if that means anything...

well, if you have any other ideas, i'd be very gratefule, but since this
isn't an XFce problem, i'll go and try google again... (i guess this is
what you get for running a manually patched unofficial PPC port of
slackware... ;-)


On Tue, Jan 20, 2004 at 10:42:54PM +0100, Olivier Fourdan wrote:
> Hi,
> You may try
> export GDK_USE_XFT=1
> If that doesn't work then your pango install is broken.
> Cheers,
> Olivier.
> On Tue, 2004-01-20 at 23:10, Joost Kremers wrote:
> > hi list,
> > 
> > i'm currently runnig XFce4.0.3(.1), compiled from source. i notice,
> > however, that i'm not getting AA fonts in XFce (i.e., the settings manager
> > and settings dialogs, xffm, window titles, etc.) i sorta thought they would
> > come with the package...
> > 
> > i do get AA fonts in MozillaFirebird, (both in the html rendering and in
> > the menus and dialogs), which also compiled from source, linked against
> > gtk+2, just like XFce. abiword, my only other gtk+2 app, only has AA fonts
> > in the document, not in the menus and dialogs.
> > 
> > i'm probably missing something silly, but i can't find what it is. anyone
> > have a hint?
> > 
> > TIA

Joost Kremers
Life has its moments

More information about the Xfce mailing list