[Goodies-dev] xfce4-battery don't update charge level

Andrwe Lord Weber lord-weber-andrwe at renona-studios.org
Tue Mar 17 19:48:43 CET 2009

On 17.03.2009 19:00, Ali Abdallah wrote:
> Andrwe Lord Weber wrote:
>> Ali Abdallah schrieb:
>>> Andrwe Lord Weber wrote:
>>>> Hi all,
>>>> I'm using xfce4-4.6.0 on Gentoo.
>>>> The panel-plugins xfce4-battery and -power-manager don't update 
>>>> there charging level automatically.
>>>> ACPI is active in the kernel and if I'm reading the state manually 
>>>> with "cat /proc/acpi/battery/BAT0/state" both plugins update thier 
>>>> values.
>>> Not sure if i understand what you exactly mean here, please provide 
>>> more details.
>> I meant the plugins show a charging level of 99% if fully loaded 
>> although I'm working on battery mode until I use the given command to 
>> see the real chargment.
>> After using it both plugins update their percentage once.
>> It is also updated if I plug in/out the cable.
> You can do the following, lshal -m, then run the above command and see 
> if this is causing hald to update the current charge value.
I've done this and the result is like I mentioned.
As long as I'm doing nothing there is no reaction but if I use the above 
commend there is an update.
I've tried it at irregular intervals and it's always the same result.
>>>> Although the left time of charging and decharging is to high, e.g. 
>>>> if my battery is fully charged they say I can work for 27 hours.
>>>> xfce4-battery-version: 0.5.1
>>>> xfce4-power-manager-version: 0.6.4
>>> Very strange, at least in the power manager, since we read this 
>>> information from hald, and we don't accept any estimated time 
>>> greater than 8 hours!
>> The 27 hours are shown by the battery-plugin. How can I see the time 
>> using power-manager?
>>>> Regards,
>>>> Andrwe
>>> Regards,
>>> Ali. 
>> Regards,
>> Andrwe

More information about the Goodies-dev mailing list