[Goodies-commits] r3999 - in ristretto/trunk: . src

Stephan Arts stephan at xfce.org
Mon Feb 25 10:17:39 CET 2008


Author: stephan
Date: 2008-02-25 09:17:39 +0000 (Mon, 25 Feb 2008)
New Revision: 3999

Modified:
   ristretto/trunk/ChangeLog
   ristretto/trunk/src/picture_viewer.c
Log:
Update ChangeLog
modify drag_dest_set on picture_viewer



Modified: ristretto/trunk/ChangeLog
===================================================================
--- ristretto/trunk/ChangeLog	2008-02-24 17:41:24 UTC (rev 3998)
+++ ristretto/trunk/ChangeLog	2008-02-25 09:17:39 UTC (rev 3999)
@@ -1,3 +1,22 @@
+xxxx-xx-xx: Release 0.0.18
+	* src/picture_viewer.c:
+	  - Improved zoom-box
+	  - Added rudimentary drag-n-drop support for opening images
+	* src/navigator.c,
+	  src/main.c,
+	  src/main_window.c,
+	  src/picture_viewer.c:
+	  - Removed duplicate code for opening files and folders, moved this
+	    to the navigator (Bug #3866)
+	* src/main.c:
+	  - Open files and folders when the main-loop is running, this way the
+	    window is already usable before the images are being opened.
+	* src/main_window.c:
+	  - Add configuration option to toggle the folowing feature:
+	    - Prevent images to be scaled beyond 100% when maximizing the window
+	    - Resize images to fit to the window when restoring the window from
+	      maximize state.
+
 2008-02-17: Release 0.0.17
 	* src/picture_viewer.c:
 	  - Fix segfault when scrolling over the picture-viewer (Bug #3824)

Modified: ristretto/trunk/src/picture_viewer.c
===================================================================
--- ristretto/trunk/src/picture_viewer.c	2008-02-24 17:41:24 UTC (rev 3998)
+++ ristretto/trunk/src/picture_viewer.c	2008-02-25 09:17:39 UTC (rev 3999)
@@ -185,7 +185,7 @@
     g_signal_connect(G_OBJECT(viewer), "popup-menu", G_CALLBACK(cb_rstto_picture_viewer_popup_menu), NULL);
 
     gtk_drag_dest_set(GTK_WIDGET(viewer), 0, drop_targets, G_N_ELEMENTS(drop_targets),
-                      GDK_ACTION_COPY | GDK_ACTION_LINK | GDK_ACTION_MOVE);
+                      GDK_ACTION_COPY | GDK_ACTION_LINK | GDK_ACTION_MOVE | GDK_ACTION_PRIVATE);
 }
 
 static void




More information about the Goodies-commits mailing list