[xfce4-terminal] Large delay in prompt echoing after completion of a command which runs inside a tmux session

Igor Zakharov f2404 at yandex.ru
Tue Sep 26 17:18:22 CEST 2017

26.09.2017, 11:05, "Daniel Fishman" <quantera at gmail.com>:
>>  The problem is looking really weird, however, especially given with the fact that you can only reproduce it on a 32-bit machine. Have you tried only one 32-bit machine? Do you have another 32-bit one for a test?
>>  Another strange thing is that gnome-terminal does not seem to have the problem, though it's also based on the vte widget. What gnome-terminal version have you tried?
> Unfortunately, I have only one 32-bit machine, the other one is 64-bit.
> I can find another 64-bit machine to test, bit not the 32-bit one.
> Therefore my suggestion that the difference lies in the processor is
> not really strong, it actually may be something to do with timing
> and some kind of a race condition that just happens on one machine
> but not another due to speed difference.
> I used gnome-terminal 3.24.2 (which says that it is using vte 0.48.3).

It would definitely help if you tested it on another machine. I wasn't able to reproduce the problem on the 64-bit one that I have here.


More information about the Xfce4-dev mailing list