[Xfce4-commits] <xfce4-session:master> Reuse existing ConsoleKit sessions (bug #6685).

Enrico Tröger enrico at xfce.org
Sun Sep 19 15:03:38 CEST 2010

On Sun, 19 Sep 2010 14:15:19 +0200, Yves-Alexis wrote:

>> Since ages, I start Xfce after logging into a console with
>> 'startxfce4' and except the Policykit/Consolekit mess, it
>> always worked perfectly.
>Which is doomed to fail, because startxfce4 has no way (and shouldn't,
>anyway) to know everything to start. In Debian, we
>use /etc/X11/Xsession.d for that, where the stuff you install put
>scripts to be run when the session is run.

Ok, I realise we are not supposed to use startxfce4 anymore. Sad but ok.

>> > The “correct” way to do it, using console is:
>> > 
>> > * install consolekit
>> > * don't use a .xinitrc
>> > * don't call startxfce4
>> > * put “exec startxfce4" in .xsessionrc
>> > * call startx (*only*, no arg, nothing)
>> > 
>> > This way, scripts in /etc/X11/Xsession.d will be executed, and
>> > especially 90consolekit, which will start it for you.
>> Thanks.
>> Done that exactly like this but it doesn't help.
>> Same result: no reboot/halt/mount.
>Sorry, I was wrong, it's not .xsessionrc (which is only sourced,
>by /etc/X11/Xsession.d/40x11-common_xsessionrc and is useful to export
>some envvar), it's .xsession:

Ok, thanks.
That took me a bit further:
With my .xsession I can now start X and Xfce starts up, partly.
It stops with the following message:

"Unable to determine failsafe session name.  Possible causes: xfconfd
isn't running (D-Bus setup problem); environment variable
$XDG_CONFIG_DIRS is set incorrectly (must include
"/home/enrico/apps/xfce/etc"), or xfce4-session is installed

$XDG_CONFIG_DIRS contains /home/enrico/apps/xfce/etc though I think it
should be /home/enrico/apps/xfce/etc/xdg. Jannis?

But actually, xfconfd is not running when this message appears. That
leads me to the question who usually starts xfconfd?

In /etc/X11/Xsession.options I disabled "use-session-dbus" so
dbus-launch is used within Xfce's xinitrc script. Then the message
disappears, Xfce starts up completely and the logout dialog offers
Reboot/Halt. But when choosing e.g. Reboot, it asks for the root
password. So it also won't properly but this might be because of the
late start of the session bus *after* Xsession stuff.
But why doesn't it work with the early started DBus session bus?
Any ideas?


Get my GPG key from http://www.uvena.de/pub.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20100919/2b309736/attachment.pgp>

More information about the Xfce4-dev mailing list