[Xfce4-commits] <xfce4-session:master> Reuse existing ConsoleKit sessions (bug #6685).

Enrico Tröger enrico at xfce.org
Sun Sep 19 13:05:42 CEST 2010

On Wed, 08 Sep 2010 13:43:09 +0200, Yves-Alexis Perez
<corsac at debian.org> wrote:
> On 08/09/2010 12:54, Enrico Tröger wrote:
>> Now, with the change above, I can't do any of these things.
>> xfce4-session-logout only offers Logout, reboot and halt are
>> disabled. Also mounting my USB stick doesn't work with this change.
>> Has anyone else similar problems or is just me?
>> Btw, all this happens on Debian Testing.
> I assume consolekit is installed? Is it correctly started? What does
> 'ck-list-session' return? How *exactly* do you start xfce?

consolekit is installed.

	unix-user = '1000'
	realname = 'Enrico Tröger'
	seat = 'Seat1'
	session-type = ''
	active = FALSE
	x11-display = ''
	x11-display-device = ''
	display-device = '/dev/tty1'
	remote-host-name = ''
	is-local = TRUE
	on-since = '2010-09-08T10:42:41.507107Z'
	login-session-id = '4294967295'
	idle-since-hint = '2010-09-08T12:13:46.014734Z'

(this is the only listed session)
Lately, with Nick's ck-l-s command in e/x/x/xinitrc, I got way
more sessions and always one with "active = True" which seems
to be a key requirement for things to work.

Maybe calling ck-l-s within xfce4-session is just too late?

Since ages, I start Xfce after logging into a console with
'startxfce4' and except the Policykit/Consolekit mess, it
always worked perfectly.

> There's a README.Debian in xfce4-session which helps for that, but it
> applies more to Xfce 4.6 so I'm not sure it'd work for 4.7.

Just to clarify: I don't use Debian packages, running it all from GIT

> The “correct” way to do it, using console is:
> * install consolekit
> * don't use a .xinitrc
> * don't call startxfce4
> * put “exec startxfce4" in .xsessionrc
> * call startx (*only*, no arg, nothing)
> This way, scripts in /etc/X11/Xsession.d will be executed, and
> especially 90consolekit, which will start it for you.

Done that exactly like this but it doesn't help.
Same result: no reboot/halt/mount.


P.S.: sorry for the late reply. I sent this mail already on Wednesday
last week but somehow the mail didn't make it to the list.


Get my GPG key from http://www.uvena.de/pub.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20100919/a08cdc50/attachment.pgp>

More information about the Xfce4-dev mailing list