[Xfce4-commits] <xfce4-verve-plugin:master> Fix compatibility with Xfce 4.7+

Florian Rivoal frivoal at gmail.com
Fri Nov 5 16:08:48 CET 2010

> Ideally, the plugin would depend on libxfce4ui, as libxfcegui4 is sorta
> deprecated. We only ship it for compatiblity reasons, just like
> thunar-vfs, which is no longer supposed to being used.

I know, but goodies are not released in sync with core xfce stuff, so I my  
idea was to follow a slightly different plan, to make the transition  

For all the panel plugins I maintain that use libxfcegui4, I am fixing  
them right now so that they will be able to run with libxfcegui4 on xfce  
4.7/4.8, and I'll make a release fixed that way before the release of xfce  
4.8, so that people/distros running xfce 4.6 can benefit from all the  
improvements to these plugins, even before they switch to 4.8 (which could  
be in quite a while), and that people working on the transition to 4.8 can  
use them too.

Then 4.8 gets released, and the panel plugins are functional, despite  
using a deprecated API.

Only after that, I'll migrate them to libxfce4ui, and drop support for  

I am not going to write new code using libxfcegui4, but I also don't want  
to drop support for xfce 4.6 while it is still the latest stable release.

Does this make sense?

  - Florian

More information about the Xfce4-dev mailing list