Xfconf troubles

Enrico Tröger enrico.troeger at uvena.de
Thu Jul 10 10:39:39 CEST 2008


yesterday I compiled the latest SVN version of Xfce (include xfconf
and xfce4-settings) but didn't restart Xfce.

So, as I booted my system today, it made Boom and I got the changes.
The changes mean that I lost most my settings for xfdesktop and the
whole UI stuff.

I had to reconfigure my GTK theme, icon theme, xfdesktop config and
similar. Most of these weren't a problem except for two things:
a) I ended up with scary fonts...I'm not able to make the fonts look
like before. This is really, really annoying and hard to describe but
my system looks ugly. I already tried all the fonts I've installed here
(which didn't change lately, so I have the same installed as before).
And I tried various hinting settings. All without any noticeable

Then I tried to play with setting a custom DPI value, as default 96 was
displayed but it wasn't active. I activated the checkbox and decreased
the value, this caused even more strange UI effects and finally killed
all my terminals and didn't let me restart it until I restarted my
whole X server.

The settings dialog for xfdesktop didn't allow me to add a custom
wallpaper. It provided a list of installed wallpapers but the little
"+" (plus) button for adding other files is insensitive. Furthermore,
IMO this button should be a real GTK stock button including the text
"Add" not only the icon.

Finally, I found this message in the logs which may be related to all
my problems with the new xfconf stuff which was just disappointing and
frustrating so far (it kept me successfully from being productive
instead I still fiddle around with these weird font settings :( ).

** (xfce4-session:3092): WARNING **: Unable to launch
"/home/enrico/apps/xfce-svn/share/xfce4/xfconf-migration/xfdesktop-xfconf-migration.pl" (specified
by autostart/xfconf-xfdesktop-migration-4.6.desktop): Kindprozess
konnte nicht ausgeführt werden (Keine Berechtigung)

I'm sorry this message is in German, the basic message is
'xfdesktop-xfconf-migration.pl couldn't be executed because it has no
executable bit set'.
Then I chmod'ed this file with 'chmod +x' to give it the executable bit
and ran it, and according to the output it worked but nothing has

Am I doing something basically wrong?
I hope so unless I'd suggest to all users to make a backup of their
Xfce config before using this new code to prevent loosing their
settings like me :(.


Get my GPG key from http://www.uvena.de/pub.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://mail.xfce.org/pipermail/xfce4-dev/attachments/20080710/3a9eea1c/attachment.pgp>

More information about the Xfce4-dev mailing list