panel plugin naming conventions

Nick Schermer nickschermer at
Wed May 16 20:04:45 CEST 2007

It looks like a stamp, but it's not:

/* unique number: pseudo-random time() + counter */
g_snprintf (id, 30, "%ld%d", (glong) time (NULL), counter++);

This to prevent the same name when multiple items are handled in 1 second.


More information about the Xfce4-dev mailing list