xfdesktop menu file location problem

Zach Carter linux at zachcarter.com
Sat Mar 31 20:32:59 CEST 2007

Enrico Tröger wrote:
> On Sat, 31 Mar 2007 09:48:41 +0200, Jannis Pohlmann <jannis at xfce.org>
> wrote:
>> On Fri, 30 Mar 2007 12:53:20 +0200, Enrico Tröger wrote:
>>> On Fri, 30 Mar 2007 12:39:57 +0200, <info at sten-net.de> wrote:
>>>> Hey,
>>>> On Fri, 30 Mar 2007 11:55:14 +0200, Enrico Tröger
>>>> <enrico.troeger at uvena.de> wrote:
>>>>> Hi,
>>>>> I just tested the new xfdesktop menu stuff. But my first test
>>>>> was a bit disappointing because after compiling and installing
>>>>> the current SVN version the whole menu disappears(the right
>>>>> click menu on the desktop as well as the panel-plugin menu).
>>>>> I got the message: Could not locate a menu definition file. So I
>>>>> started to have a look at the code and what is going on on my
>>>>> system.
>>>>> xfdesktop (or libxfce4menu, not sure) installs the file
>>>>> xfce-applications.menu in etc/xdg/menus. Probably this works on
>>>>> most systems, but not on mine.
>>>>> I have my complete Xfce installed
>>>>> in /home/enrico/apps/xfce-svn/, so the menu file is located
>>>>> in /home/enrico/apps/xfce-svn/etc/xdg/menus. But xfdesktop
>>>>> didn't find it there. After copying the file into
>>>>> ~/.config/menus the panel-plugin menus appears and looks fine.
>>>>> So, did I anything wrong while compiling and installing(I do it
>>>>> the same way like before since about a year). Or may it be a
>>>>> bug in the menu file location code of xfdesktop?
>>>> You need to export XDG_CONFIG_DIRS or XDG_CONFIG_HOME like
>>>>   export XDG_CONFIG_DIRS=
>>>> $XDG_CONFIG_DIRS:/home/enrico/apps/xfce-svn/etc/xdg or
>>>>   export XDG_CONFIG_HOME=
>>>> $XDG_CONFIG_HOME:/home/enrico/apps/xfce-svn/etc/xdg
>>>> I don't remember how xfdesktop does it, but in theory this should
>>>> work.
>>> Nope but thanks anyway.
>> Update your SVN checkout - we just found out what was wrong. Just do
>>   export XDG_CONFIG_DIRS=/home/enrico/apps/xfce-svn/etc/xdg:/etc/xdg
>> and it will work.
> Thanks a lot. All is working now as expected, yeah. Great work.

I've been having a similar problem with the right-click menu.  The panel menu has been working fine
the whole time.  I just updated my SVN checkout, rebuilt xfdesktop with --prefix=/opt/xfce-dev, and
the right-click menu is still not working for me with these paths:

export PATH=/opt/xfce-dev/bin:$PATH
export XDG_CONFIG_DIRS=/opt/xfce-dev/etc/xdg:/etc/xdg

Also, I tried just running this: /opt/xfce-dev/bin/xfdesktop -menu, which produced nothing.

Any other ideas?  Should I file a bug on this?  I'll poke around some more and see what I can find out.


More information about the Xfce4-dev mailing list