Can Xfce depend on Gtk+ 2.10?

Jasper Huijsmans jasper at
Sun Aug 26 10:35:49 CEST 2007

2007/8/23, Erik Harrison <erikharrison at>:
> On 8/23/07, Nick Schermer <nickschermer at> wrote:
> > First: don't reply on this discussion with the default 'yeah go for
> > it!' message, but give arguments if you see advantages or even better:
> No distro that -wants- to ship a 2,8 or earlier version of Gtk+ (For
> whatever reason) is going to ship Xfce 4.6. Gtk+ 2.12 will be out by
> the time we're shipping 4.6.
> The problem is Xfce's historical desire to make Xfce available for
> people who can't upgrade their distro, generally for hardware reasons.
> We must assume that if we depend on Gtk+ 2.8 or higher, these users
> will need to upgrade their Gtk+ too, which means compiling by hand.
> Upgrading a system from Gtk+ 2.6 to 2.8 is an unholy BITCH. I never
> could get my old slackware machine properly upgraded without breaking
> everything, and it took trial and error to build a version of the G*
> stack in the first place, even if it was broken.
> 2.10 has the same problems - which is why I advocate jumping on 2.10.
> A 2.8 dependency means that people who keep their distro up to date
> will have a more recent version of Gtk+ anyway, and those who don't
> will have such a hellish time upgrading their system, that they might
> as well upgrade to 2.10. And we might as well cut out them ifdefs.

If thunar depends on 2.10, there's not much to gain from keeping the
(rest of the) core Xfce components on 2.8, is there?

Getting rid of our own status icon implementation is a good enough
reason for me to switch. The systray has enough weird behavior with
two available implementations (Gtk and Qt).


More information about the Xfce4-dev mailing list