xfce4- can't find vte location

Benedikt Meurer benedikt.meurer at unix-ag.uni-siegen.de
Thu Jul 13 10:39:04 CEST 2006

Dale wrote:
> Hi there
> The installer cannot find my vte.pc file. I've tried to help it along by 
> modifying PKG_CONFIG_PATH and by specifying the location manually. The 
> installer refuses to enable the Next button and still shows that vte 
> 0.11.11 or above is not found.
> xfce4-
> vte-0.12.0 is installed on my system.
> vte.pc is at /usr/lib/pkgconfig/vte.pc
> I tried:
> # PKG_CONFIG_PATH="/usr/lib/pkgconfig:$PKG_CONFIG_PATH"
> # export PKG_CONFIG_PATH
> Any pointers would be appreciated.

I dunno what would cause this problem, maybe your system has a second
vte.pc for a version < 0.11.11.

Anyway, here's a workaround to get you started:

(1) Extract the installer in /tmp using ./xfce4-
(2) Go to /tmp/xfce4- and apply the attached patch
with patch -Np0 < /path/to/main.c.patch (this will remove the VTE
dependency check, pray that Terminal's configure will be able to locate
the appropriate vte.pc)
(3) Now run ./bootstrap.sh and install as usual.

> Thanks
> Dale


More information about the Xfce4-dev mailing list