Error with ./ at libxfce4util from SVN

Łukasz Hejnak sziftgroup at
Fri Nov 11 22:47:47 CET 2005


Firstly, sorry for my english ;]
I looked for a similar problem within the lists archives but nothing 
there that would be connected with this.

Today I thought of upgrading my XFCE to the svn for some bug testing
The thing is, I'm having problems with the ./ script in 
libxfce4util. It only generates just the four files: install-sh, 
missing, compile and depcomp

szift at szift:/usr/src/xfce/trunk/libxfce4util$./
Preparing package directory /usr/src/xfce/trunk/libxfce4util...
Running libtoolize --force --copy...
Running gtkdocize --copy...
Running aclocal-1.9   -I /usr/local/xfce/share/xfce4/dev-tools/m4macros...
Running autoheader...
Running automake-1.9 --add-missing --copy --gnu... installing `./install-sh' installing `./missing'
gtk-doc.make:7: GTK_DOC_USE_LIBTOOL does not appear in AM_CONDITIONAL
docs/   `gtk-doc.make' included from here
gtk-doc.make:43: ENABLE_GTK_DOC does not appear in AM_CONDITIONAL
docs/   `gtk-doc.make' included from here
gtk-doc.make:134: ENABLE_GTK_DOC does not appear in AM_CONDITIONAL
docs/   `gtk-doc.make' included from here
libxfce4util/ installing `./compile'
libxfce4util/ installing `./depcomp'

and the generated files are (I cut out the files downloaded from the 
repository except for, and

-rw-r--r--  1 szift root 261932 2005-11-11 22:23 aclocal.m4
-rwxr-xr-x  1 szift root    798 2005-11-11 18:39
drwxr-xr-x  2 szift root   4096 2005-11-11 22:24 autom4te.cache
-rwxr-xr-x  1 szift root   3703 2005-11-11 22:24 compile
-rwxr-xr-x  1 szift root  43610 2005-11-11 22:23 config.guess
-rw-r--r--  1 szift root   3281 2005-11-11 22:24
-rwxr-xr-x  1 szift root  31495 2005-11-11 22:23 config.sub
-rw-r--r--  1 szift root   5783 2005-11-11 22:23
-rw-r--r--  1 szift root   5788 2005-11-11 18:39
-rwxr-xr-x  1 szift root  15868 2005-11-11 22:24 depcomp
-rw-r--r--  1 szift root   4532 2005-11-11 22:23 gtk-doc.make
-rwxr-xr-x  1 szift root   9233 2005-11-11 22:24 install-sh
-rw-r--r--  1 szift root 185213 2005-11-11 22:23
-rw-r--r--  1 szift root    560 2005-11-11 18:39
-rwxr-xr-x  1 szift root  10872 2005-11-11 22:24 missing

I did have a problem concerning Docbook, as the gtk-doc didn't want to 
go trough.. but after some work I got it working, and it seems to be ok, 
at least the gtk-doc installed ok.

As for my system, it's a HLFS (Hardened Linux From Scratch)
with kernel, but I don't think this has influence in 
here, the other tools are:
automake (GNU automake) 1.9.5
aclocal (GNU automake) 1.9.5
autoconf (GNU Autoconf) 2.59
autoheader (GNU Autoconf) 2.59
libtoolize (GNU libtool) 1.5.14
gtkdocize (gtk-doc) 1.4

So did anybody have seen anything like this? or maybe has an idea why 
this is happening and maybe even how to fix it ;]

Best wishes

PS. I don't know why, but I tried to subscribe here from my 
mail adress (I run a server on that domain) and I got an answer that I 
can't subscribe from *.org domains.. so I thought to try from this 
adress, but since then I'm blocked from connecting too
I don't know why though, I looked for it's IP in my 'block list' as I 
use ipt_recent and some hard rules for some ports that people like to 
scan too much, but it's not there, and so to get subscribed I needed to 
use an anonymous proxy.

More information about the Xfce4-dev mailing list